Installation of Robot Framework Editor Ride Download with pip


Robot Framework is a generic test automation framework for acceptance level testing. RIDE is a lightweight and intuitive editor for Robot Framework test data.

To install the ride the system need to have the below package installed.

Open your command prompt and enter the below commnet.

 pip install robotframework-ride 
Collecting robotframework-ride
Downloading https://files.pythonhosted.org/packages/4e/a6/1835a17fa566b19c166735a9a75d55101e53b68566771ddb0b690dd4be83/robotframework_ride-1.7.3.1-py2.py3-none-any.whl (926kB)
100% |████████████████████████████████| 931kB 60kB/s
Collecting Pypubsub==3.3.0 (from robotframework-ride)
Downloading https://files.pythonhosted.org/packages/95/5a/1801be1a63af9250e79b8941a37b88e3ca0d660b880b9862fe9016ae6a3a/PyPubSub-3.3.0.zip (87kB)
100% |████████████████████████████████| 92kB 65kB/s
Collecting Pygments (from robotframework-ride)
Downloading https://files.pythonhosted.org/packages/13/e5/6d710c9cf96c31ac82657bcfb441df328b22df8564d58d0c4cd62612674c/Pygments-2.3.1-py2.py3-none-any.whl (849kB)
100% |████████████████████████████████| 849kB 46kB/s
Collecting robotframeworklexer (from robotframework-ride)
Downloading https://files.pythonhosted.org/packages/24/18/ad01d42227d824b890f1b4d32237e5003bf7afe8764cb13545fb63d7fcb5/robotframeworklexer-1.1-py3-none-any.whl
Collecting wxPython (from robotframework-ride)
Downloading https://files.pythonhosted.org/packages/5b/1c/f1b46a9c79c572ab35276d6f07023a2794cc5b76a38723332ec653d365ff/wxPython-4.0.4-cp37-cp37m-win32.whl (14.0MB)
100% |████████████████████████████████| 14.0MB 78kB/s
Requirement already satisfied: robotframework in c:\python 37\lib\site-packages (from robotframework-ride) (3.1.1)
Collecting Pywin32 (from robotframework-ride)
Downloading https://files.pythonhosted.org/packages/8a/37/917c4020e93e0e854d4cbff1cbdf14ec45a6d1cedf52f8cafdea5b22451a/pywin32-224-cp37-cp37m-win32.whl (8.3MB)
100% |████████████████████████████████| 8.3MB 134kB/s
Requirement already satisfied: six in c:\python 37\lib\site-packages (from wxPython->robotframework-ride) (1.12.0)
Requirement already satisfied: Pillow in c:\python 37\lib\site-packages (from wxPython->robotframework-ride) (5.4.1)
Installing collected packages: Pypubsub, Pygments, robotframeworklexer, wxPython, Pywin32, robotframework-ride
Running setup.py install for Pypubsub … done
Successfully installed Pygments-2.3.1 Pypubsub-3.3.0 Pywin32-224 robotframework-ride-1.7.3.1 robotframeworklexer-1.1 wxPython-4.0.4

Leave a Reply

Your email address will not be published. Required fields are marked *